Wednesday, January 6, 2016

UNEQUAL 2 WAN LOAD BALANCING PCC

5 comments:

  1. /ip address
    add address=192.168.1.10/24 interface=ether1
    add address=192.168.2.10/24 interface=ether2
    add address=192.168.10.1/24 interface=ether5

    /ip dns
    set allow-remote-requests=yes cache-size=5000KiB max-udp-packet-size=2048 servers=192.168.1.1,192.168.2.1

    /ip firewall mangle
    add chain=input in-interface=ether1 action=mark-connection new-connection-mark=WAN1_con
    add chain=input in-interface=ether2 action=mark-connection new-connection-mark=WAN2_con
    add action=mark-routing chain=output connection-mark=WAN1_con new-routing-mark=to_WAN1
    add action=mark-routing chain=output connection-mark=WAN2_con new-routing-mark=to_WAN2
    add chain=prerouting dst-address=192.168.1.0/24 in-interface=ether5
    add chain=prerouting dst-address=192.168.2.0/24 in-interface=ether5
    add action=mark-connection chain=prerouting dst-address-type=!local hotspot=auth in-interface=ether5 new-connection-mark=WAN1_con per-connection-classifier=both-addresses-and-ports:2/0
    add action=mark-connection chain=prerouting dst-address-type=!local hotspot=auth in-interface=ether5 new-connection-mark=WAN2_con per-connection-classifier=both-addresses-and-ports:2/1
    add action=mark-connection chain=prerouting dst-address-type=!local hotspot=auth in-interface=ether5 new-connection-mark=WAN1_con per-connection-classifier=both-addresses-and-ports:2/2
    add action=mark-routing chain=prerouting connection-mark=WAN1_con in-interface=ether5 new-routing-mark=to_WAN1
    add action=mark-routing chain=prerouting connection-mark=WAN2_con in-interface=ether5 new-routing-mark=to_WAN2

    /ip firewall nat
    add action=masquerade chain=srcnat out-interface=ether1
    add action=masquerade chain=srcnat out-interface=ether2

    /ip route
    add check-gateway=ping distance=1 gateway=192.168.1.1 routing-mark=to_WAN1
    add check-gateway=ping distance=1 gateway=192.168.2.1 routing-mark=to_WAN2
    add check-gateway=ping distance=1 gateway=192.168.1.1
    add check-gateway=ping distance=2 gateway=192.168.2.1

    ReplyDelete
  2. bahi mary pass 10+4 kay link ha os k leay may ny ya script use kea ha wan 1 to ok chal rahi ha but wan 2 perform ne kar rahi kya problem ha\

    ReplyDelete
  3. Slam Sir mjhy 2 wan load balancing ki cript recquired hai wan1 and wan 2,,wan 2 se bandwith kam use ho aur wan2 se bandwith zayda use ho please

    ReplyDelete
  4. bhai maine ap se 1 sawaal pouchna hai k yr maine dream intenet se fiber pr link liya howa hai or meray pass 24mbps speed hai or mikrotik routerboard pr mera server bana howa hai pppoe or bhai masla yeh arha hai k download jab mai local server dream net jo hai emasti.pk mikrotik se jab mai connect hokr yeh server se downloading kr rha hu tou kbps mai downloading arhe hai jab k yeh tou 1 local sharing server hai nah dream network ka is tou mbps mai downloading ani chaahiye or bhai maine direct tplink pr downloading emasti.pk se checck ki hai tou 1mbps se ly kr 10mbps tak downloading arhe hai so please help me brother...

    ReplyDelete
    Replies
    1. Sb kuch apko yahi sekhadngy tw paisy kaisy kamingy log?

      Delete