Friday, June 23, 2017

High Priority For Speed Test 8Mb Per User (speedtest.net)



/ip firewall layer7-protocol
add name=SpeedTest regexp="^.+(speedtest).*\\\$"
/ip firewall mangle
add action=mark-connection chain=forward comment="Speed Test Server" \
    layer7-protocol=SpeedTest new-connection-mark=SpeedTest_Con passthrough=yes
add action=mark-connection chain=prerouting new-connection-mark=SpeedTest_Con \
    passthrough=yes protocol=tcp src-port=8080
add action=mark-packet chain=prerouting connection-mark=SpeedTest_Con \
    new-packet-mark=SpeedTest_Packets passthrough=no
add action=mark-connection chain=postrouting dst-port=8080 new-connection-mark=\
    SpeedTest_Con passthrough=yes protocol=tcp
add action=mark-packet chain=postrouting connection-mark=SpeedTest_Con \
    new-packet-mark=SpeedTest_Packets passthrough=no
/queue type
add kind=pcq name=Dow8MB pcq-classifier=dst-address pcq-dst-address6-mask=64 \
    pcq-rate=8192k pcq-src-address6-mask=64
add kind=pcq name=Up8MB pcq-classifier=src-address pcq-dst-address6-mask=64 \
    pcq-rate=8192k pcq-src-address6-mask=64
/queue simple
add comment="Speed Test 8Mb Per User" name="Speed Test" packet-marks=\
    SpeedTest_Packets queue=Up8MB/Dow8MB target=192.168.2.0/24
/

24 comments:

  1. Hamza Bhi ya lo MY PC or *MB Target keya han wo kon sa han

    ReplyDelete
  2. Can it run on rb951ui 2nd?

    ReplyDelete
  3. target=192.168.2.0/24 ya server ka lan ip ha?
    yaha may apny server ka LAN ip add karo bahi jo kay 200.168100.1/24 ha??

    ReplyDelete
  4. aslm my network range is split different.very cofused sheikh

    ReplyDelete
  5. Hamza Bhai apna cell number mjy es number py SMS karein plz.0312_7201209

    ReplyDelete
    Replies
    1. Sorry, you can call me on facebook
      https://www.facebook.com/hamzakhalil202

      Delete
    2. that script can work on pppoe user ??

      Delete
  6. HI DEAR

    I USE 10.5.50.1 FOR HOTSPOT USERS , AND 23.23.23.1 FOR PPPOE USERS
    HOW I CAN ADD IP TO SCRIPT FOR ALL USERS(HOTSPOT + PPPOE)??

    ReplyDelete
  7. Mare mikrotik ma ya kam nahe kar re

    ReplyDelete
  8. 8080 ko kis port se change krna ha dear

    ReplyDelete
  9. Hi Hamza,

    Nice to see your post on this query of the customers, but it wont work until we have a backbone of more then 8 Mbps, Customers in my network are getting File download properly but they are not getting same speed on speedtest websites.

    ReplyDelete
  10. A.O.A brother mikrotik os update krna py ye work ni kr pa rhi script firewall k rules me packets capture ho rha but queue me target ip dena pr b kuch show ni krta result kindly bta dijiye shukriya.

    ReplyDelete
  11. thanks Bro... speedtest k sath agar fast.com ko bhe add karna ho to kia karna ho ga..

    ReplyDelete
  12. tam user ko 6mb ques may 1 sat kasay chala sak tay ha or agar chal jay to auto time set kasay lagay ga

    ReplyDelete
  13. Mobiles speedtest app pe speedtest profile wali ati hay is may ....

    ReplyDelete
  14. Hey great script! but i have some question. I have few simples queues that each one is a different plan (5mb, 10mb, 15mb and 20mb). Therefore i need 4 differents Speedtest server, and each plan belong to a differrent subnetwork. The whole network is 192.168.50.0/24 so i have 4 subnetwork (4 addresses lists) that is marked in mangle rule>advanced>Src. Address list that way i market the traffic for each client in specific plan. It will be enough to give like a target to the simple queue in advanced option in it?

    ReplyDelete