Friday, January 8, 2016

How to Save Mikrotik Logs to Remote ¨Syslog Server¨


syslog is a widely used standard for message logging. It permits separation of the software that generates messages, the system that stores them, and the software that reports and analyzes them.
Computer system designers may use syslog for system management and security auditing as well as general informational, analysis, and debugging messages. A wide variety of devices, such as printers and routers, and message receivers across many platforms use the syslog standard. This permits the consolidation of logging data from different types of systems in a central repository. Implementations of syslog exist for many operating systems.
Each message is labeled with a facility code, and assigned a severity label. The facility code indicates the software type of the application that generated the message.
The destination of messages may be directed to various destinations, tuned by facility and severity, including console, files, remote syslog servers, or relays.
Most implementations provide a command line utility, often called logger, as well as a link library, to send messages to the log.
Some implementations include reporting programs for filtering and displaying of syslog messages. 
You Can Use Different Syslogs Servers

/system logging action
set 3 bsd-syslog=yes remote=192.168.88.253 syslog-facility=local0
/system logging
add action=remote topics=info
add action=remote topics=hotspot
add action=remote topics=interface
add action=remote topics=pppoe
add action=remote topics=warning
add action=remote topics=error

15 comments:

  1. Replies
    1. local pc mein b ker skte hn ..ya kisi or jaga remote base pe b ker skte hn

      Delete
    2. Brother mere pass 1 link wateen ka 50MB hai aur 1 link Transworld ka 100MB hai ....mujhe 4 wan port ki marjin script chai hai plzzz mail me Adnan.medialink@gmail.com

      Delete
  2. aoa Bro is ip ki jahga 192.168.88.253 hum kya ip de ge jab ke hamari local ip 172.16.0.1 hai

    ReplyDelete
    Replies
    1. jis jaga pe save kerna hai os ka ip dena ho ga

      Delete
  3. This comment has been removed by the author.

    ReplyDelete
  4. This comment has been removed by the author.

    ReplyDelete
  5. Web log b save skty Hain ? Our kaisy

    ReplyDelete
  6. kisi or sys main kase save kar sakty hain

    ReplyDelete
  7. Hamza khalil brother log server ka complete solution do please,.........

    ReplyDelete
    Replies
    1. brother koi new method btaiyeeeeeeeeeeeeeeeeeeeeeeee.

      Delete
    2. Mikrotik ka log save kerne ka yhi method hai....
      just remote servers koi b use ker lain ... (Mikrotik log ha ye bs)

      Delete
  8. bhai maine ap se 1 sawaal pouchna hai k yr maine dream intenet se fiber pr link liya howa hai or meray pass 24mbps speed hai or mikrotik routerboard pr mera server bana howa hai pppoe or bhai masla yeh arha hai k download jab mai local server dream net jo hai emasti.pk mikrotik se jab mai connect hokr yeh server se downloading kr rha hu tou kbps mai downloading arhe hai jab k yeh tou 1 local sharing server hai nah dream network ka is tou mbps mai downloading ani chaahiye or bhai maine direct tplink pr downloading emasti.pk se checck ki hai tou 1mbps se ly kr 10mbps tak downloading arhe hai so please help me brother...

    ReplyDelete